FANDOM


Forums: Index > Help desk > Trouble modding a serpens into PC borderlands.


OK, so before anyone gets on their high horse, I do not play borderlands in multiplayer, and I never intend to. And if I did, I'd start fresh. Modding/cheating in multiplayer is dumb.


However, I do like to blow things up in the comfort of my solo games (Did the same thing in Diablo 2), which leads to my current problem: For some reason, I cannot mod a Serpens into my game. I've modded several orange guns into the game, a shield & a COM unit, and as far as Pearls go I already made a Tsunami. But for some reason I cannot get a serpens to load into the game, despite GearCalc saying it's legit. I've tried several combinations of different parts that I thought might be the cause of the problem, but none of them appear in game when I load my save. After fiddling around in Willowtree it seems it thinks something's wrong w/ them too, as it says "Expected Damage: 0".


For an example, from GearCalc:

dlc3_gd_customweapons.Pearlescent_Weapons.CustomWeap_SupportMG_SandSSerpens gd_manufacturers.Manufacturers.SandSMunitions gd_weap_support_machinegun.A_Weapon.WeaponType_support_machinegun gd_weap_combat_rifle.Body.body5 gd_weap_combat_rifle.Grip.grip3 gd_weap_support_machinegun.mag.mag2 gd_weap_combat_rifle.Barrel.barrel5 gd_weap_support_machinegun.Sight.sight1 gd_weap_combat_rifle.Stock.stock5 None dlc3_gd_weap_UniqueParts.SupportMachineGun.acc4_SandS_Serpens dlc3_gd_weap_UniqueParts.SupportMachineGun.SandSSerpens_Material gd_weap_support_machinegun.Prefix.Prefix_Kick1_Glorious dlc3_gd_weap_UniqueParts.Title.TitleP_SandS_Serpens 1 2 0 24


I export that to Willowtree & when I save changes it lists it as a Glorious Serpens, so I'd think it would be correct. However, it still says Expected Damage: 0, and upon loading my saves the weapon is gone. If I save the game & return to WT, the gun is not in my inventory, as you would imagine.

I tried googling for how to fix this business but I couldn't find jack, and the Modding site doesn't seem to have any forums near as I can tell, so this was the best place I could think of. Any help would be appreciated.

Seroster 18:24, September 1, 2011 (UTC)


Go to zerosubstance.net and download the willowtree code for any of the serpens listed. That ought to allow you to figure out what's wrong. Player8410 19:23, September 1, 2011 (UTC)

The first problem I see upon a quick glance of your code is that you have mag2. S&S MGs cannot have mag2. Choose mag4 or mag5. Also, you may want to put that code into a <pre> so it's easier to read. Logisim 19:36, September 1, 2011 (UTC)

Ok I looked into this some more. It definitely appears that the mag2 is preventing it from passing the game's filter. You must choose mag4 or mag5. Also a few more notes:

  • Do not trust the damage computation in WT. It's totally inaccurate and useless information. I don't even click on "weapon info" any more. Gearcalc is much more accurate and comprehensive, but can still sometimes be wrong.
  • Just because Gearcalc says it's legit does not make it legit. Gearcalc's legitness-checking is only for the weapon's name and not parts, and sometimes does not work. It is known to give both false positives and false negatives.
  • It's not possible to obtain a quality 2 Serpens. I think all pearls must have quality 5.

Logisim 20:04, September 1, 2011 (UTC)


Well the Quality shouldn't be a problem, while trying to figure out what was wrong w/ my Serpens I made at least 2 other quality 2 pearls, a Tsunami & an Avenger. (Not that impressed w/ the Avenger... pretty meh IMO.) I will say that it seemed like I couldn't make a quality 1 pearl at all, but I don't remember what I tried on that one, and/or trying very hard at that point at all (since i hadn't made it to the DLC3 area I assumed that was the problem at the time.)

I'll try changing the magazine, though I find it odd as I have a mag2 on the Ajax's Spear + Ogre I made. Guess I R stuck w/ long reload times. Lemme try thats out. Seroster 21:37, September 1, 2011 (UTC)


I changed magazine to mag5 & indeed it worked. Not sure what the deal w/ Mag 2 is, cause my Ogre definitely has one, I looked at it in WT to make sure. Strange, strange! TY a lot though folks. For some reason I don't think I ever switched the magazines, probably cause I didn't want +25% or more reload time. Ohs well. Seroster 21:37, September 1, 2011 (UTC)

I said S&S MGs cannot have mag2. I didn't say all MGs cannot have mag2. The Spear and Ogre are Atlas products. Logisim 02:49, September 2, 2011 (UTC)

Ahh sorry. My brain is fried from watching small children & puppies all day. TY again for the fix though. Seroster 04:34, September 2, 2011 (UTC)

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.